Actualizar a la última CURL y de Open SSL en WHM

Problema:
proveedores de comercio electrónico como Paypal introdujo más estrictos requisitos de SSL. Ex:
“requiere OpenSSL >= 1.0.1 para ser instalado en el servidor”

Muestra información PHP:
RIZO
SSL versión OpenSSL/1.0.0

Fijar:

  • Instalar el último rizo:

cd / usr / local / src
wget https://Curl.haxx.se/download/CURL-7.52.1.tar.gz
tar - xvzf rizo-7.52.1.tar.gz
enrollamiento de CD *

./configurar –activar resolución de roscado –Enable-http –habilitar ftp –habilitar proxy –Enable tftp –habilitar ntlm –Enable-static –con ssl = / usr/local/ssl –habilitar ipv6 –enable-compartida –con libidn
hacer && make install

/usr/local/bin/curl –version

  • Configurar PHP para usarlo-crear un nuevo /var/cpanel/easy/apache/rawopts/all_php5 de archivo con este contenido:
    –with-Curl=/usr/local/src/CURL-7.52.1
  • Reconstruir Apache & PHP con EasyApache 3.

Resultado:

Ahora debe mostrar la información de PHP:
Rizar la información 7.52.1
SSL versión OpenSSL/1.0.1e

Instale ZMQ para PHP

wget http://download.ZeroMQ.org/ZeroMQ-4.1.0-RC1.tar.gz
tar - zxvf zeromq-4.1.0-rc1.tar.gz
CD zeromq-4.1.0
./configurar
hacer
make install

 

PECL install zmq-beta

 

Encontrar el php.ini :

php -i | grep ' archivo de configuración’

 

Compruebe si se añade la extensión:

/usr/local/lib/php.ini gato | grep ZMQ
Debe mostrar:
extension =”zmq.so”

Configurar un archivo phpinfo.php que contiene código phpinfo() en esa carpeta, para comprobar si la biblioteca está cargado.

 

Si el servidor tiene un cortafuegos, esto requiere abrir algunos puertos en el firewall para TCP. Ex: 5555, 8080. Compruebe guiones como push-server.php .