Upgradovat na nejnovější CURL a Open SSL v WHM

Problém:
e-Commerce poskytovatelů, jako je Paypal zavedeny přísnější požadavky SSL. Ex:
“vyžaduje OpenSSL >= 1.0.1 nainstalována na vašem serveru”

Zobrazuje informace o PHP:
CURL
SSL verze OpenSSL/1.0.0

Oprava:

  • Nainstalujte nejnovější CURL:

CD texty
wget https://Curl.haxx.se/Download/Curl-7.52.1.tar.gz
tar - xvzf curl-7.52.1.tar.gz
CD curl *

./Konfigurace –Povolit-se závitem překladač –Enable http –Povolit ftp –Povolit proxy –tftp povolit –Povolit ntlm –Enable statický –s ssl = / usr/local/ssl –povolení ipv6 –povolení sdíleného –s běhová
Značka && Proveďte instalaci

/usr/local/bin/curl –verze

  • Konfigurace PHP používat-vytvořit nový soubor /var/cpanel/easy/apache/rawopts/all_php5 s tímto obsahem:
    –with-Curl=/usr/local/src/Curl-7.52.1
  • Znovu sestavit Apache & PHP s EasyApache 3.

Výsledek:

Informace o PHP by měl nyní zobrazit:
Zkroucení informace 7.52.1
SSL verze OpenSSL/1.0.1e

Nejlepší pluginy pro optimalizaci a zabezpečit WordPress

Urychlení a zajištění

  1. WordFence
    Povolit bránu firewall, periodické kontroly, Neúspěšné přihlášení bloku, bezpečná hesla.
  2. WP Super Cache
    Zrychlit doručování statický obsah a stránky: Konfigurujte pro návštěvníky, aby se zabránilo přetížení roboty/prohledávací moduly.
  3. Pomocí Google knihoven
    Zatížení JS z CDN. Snížit zatížení.
  4. WPS skrýt přihlášení
    Chraňte před hrubou přihlášení.
  5. Soubor robots.txt
    Upravit soubor robots.txt.
  6. Really Simple SSL
    Přesměrování stránky na HTTPS (SSL vyžaduje).
  7. Snadné WP SMTP
    Použít účet, posílat e-maily s nezbytných ověření omezit filtrování nevyžádané pošty a ztracené e-maily.

Nástroje pro odstraňování problémů

  1. P3 Plugin výkonu Profiler
  2. Server IP & Zobrazení využití paměti

Konfigurace

  • soubor robots.txt

    User agent: *
    Zpoždění prohledávání: 90
    Zakázat: /wp-admin /
    Zakázat: /WP-obsahuje /
    Zakázat: /proudy /
    Zakázat: /wp-login.php
    Zakázat: /WP *

    User agent: MJ12bot
    Zakázat: /